Bug #75

Opstarten NNTPGrab (normale en 64bit) duurt erg lang op Windows vista

Added by Renzzie over 3 years ago. Updated over 2 years ago.

Status:In Progress Start:03/22/2011
Priority:Normal Due date:
Assigned to:Alguno % Done:

0%

Category:Qt GUI (regular GUI)
Target version:0.7.0
Votes: 0

Description

Het duurt echt vreselijk lang (ruim een minuut) voordat NNTPGrab is opgestart. Dit zowel voor de 32 als 64bit versie.

Ik had hier geen last van met de vorige updates.
De versie die ik gebruik is: 0.6.91

Mijn (wellicht niet nodige?) systeeminfo:
Windows Vista 64bit
Intel dual core E6600 @ ~3,2ghz
Gtx 275
4gb ram
500 gb schijf, waarvan 200gb vrij

Associated revisions

Revision 1822
Added by Alguno over 3 years ago

Fixes a possible assertion error in the Qt frontend on Win32 as mentioned in issueID #75

History

Updated by chrashoverraid over 3 years ago

Heb je soms je queue erg vol staan?
Want dit kan de boel ook merkbaar vertragen.

Updated by Renzzie over 3 years ago

chrashoverraid wrote:

Heb je soms je queue erg vol staan? Want dit kan de boel ook merkbaar vertragen.

Neen, zelfs met een lege queue of amper volle queue duurt het opstarten bijna een minuut.

Updated by chrashoverraid over 3 years ago

Hier doet het er ongeveer een seconden of 5 over. Wat duurt er precies lang?
Doet het lang voordat dit scherm komt: http://www.nntpgrab.nl/screenshots/connect_0_6_1_fedora.png
Of nadat je hier op "Start standalone" druk?

Updated by Renzzie over 3 years ago

chrashoverraid wrote:

Hier doet het er ongeveer een seconden of 5 over. Wat duurt er precies lang? Doet het lang voordat dit scherm komt: http://www.nntpgrab.nl/screenshots/connect_0_6_1_fedora.png Of nadat je hier op "Start standalone" druk?

Dat scherm krijg ik niet (meer).
Heb eerder een reinstall geprobeerd, maar zal dit morgen nog een keer doen. Wellicht verhelpt dit het probleem.

Updated by Renzzie over 3 years ago

Renzzie wrote:

chrashoverraid wrote:

Hier doet het er ongeveer een seconden of 5 over. Wat duurt er precies lang? Doet het lang voordat dit scherm komt: http://www.nntpgrab.nl/screenshots/connect_0_6_1_fedora.png Of nadat je hier op "Start standalone" druk?

Dat scherm krijg ik niet (meer). Heb eerder een reinstall geprobeerd, maar zal dit morgen nog een keer doen. Wellicht verhelpt dit het probleem.

Heb een reinstall gedaan via de wizard (ook de data in C:\Users\*naam*\AppData\Roaming verwijderd).
Het scherm wat jij krijgt krijg ik idd binnen 5seconden. Als ik echter aanvink 'laat scherm niet meer zien' duurt het opstarten daarna nog iets van 25 seconden. Weet niet of het zo lang moet duren?

Updated by Alguno over 3 years ago

Voor Windows omgevingen zijn er momenteel 2 versies van NNTPGrab die je kan opstarten, namelijk de standaard frontend (Qt-gebaseerd) een een Gtk-gebaseerde versie.
Als het goed is zou in het start-menu van Windows ook een snelkoppeling aanwezig moeten zijn voor deze Gtk-gebaseerde versie.
Heb je dit probleem met beide versies of met maar 1 van de 2 ?

Updated by Renzzie over 3 years ago

Alguno wrote:

Voor Windows omgevingen zijn er momenteel 2 versies van NNTPGrab die je kan opstarten, namelijk de standaard frontend (Qt-gebaseerd) een een Gtk-gebaseerde versie. Als het goed is zou in het start-menu van Windows ook een snelkoppeling aanwezig moeten zijn voor deze Gtk-gebaseerde versie. Heb je dit probleem met beide versies of met maar 1 van de 2 ?

Ik heb 2 versies in menu start staan:
NNTPGrab (64bit)
NNTPGrab (GTK Frontend 64bit)

de eerste start traag op, de GTK frontend start snel op.
Probleem voor mij dus verholpen :D

Wat is echter het verschil tussen deze twee versies?

Updated by Alguno over 3 years ago

  • Category set to Qt GUI (regular GUI)
  • Status changed from New to In Progress
  • Assigned to set to Alguno
  • Target version set to 0.7.0

Het verschil tussen deze 2 versies zit hem in de grafische elementen (windows, knopjes enzo).
Het is wel zeer opmerkelijk dat de Qt versie (de standaard vanaf NNTPGrab 0.6.91) zo traag op start bij jou onder Windows.
Zou je eens kunnen proberen of http://snapshots.nntpgrab.nl/win64/unstable-trunk/nntpgrab_trunk_snapshot_svn_r1821_setup_x64.exe beter werkt? Deze bevat namelijk een meer recente versie van Qt

Updated by Renzzie over 3 years ago

Alguno wrote:

Het verschil tussen deze 2 versies zit hem in de grafische elementen (windows, knopjes enzo). Het is wel zeer opmerkelijk dat de Qt versie (de standaard vanaf NNTPGrab 0.6.91) zo traag op start bij jou onder Windows. Zou je eens kunnen proberen of http://snapshots.nntpgrab.nl/win64/unstable-trunk/nntpgrab_trunk_snapshot_svn_r1821_setup_x64.exe beter werkt? Deze bevat namelijk een meer recente versie van Qt

Als ik die versie installeer over de laatste NNTPGrag heen (niet eerst gedeinstalleerd) krijg ik de volgende foutmelding:
ASSERT: "cb_data->active_collection->collection_name==Qstring(collection_name)" in file QNNTPgrabGlue.cpp, line 706.
Als ik daar op ok druk krijg ik daarna een Microsoft visual C++ error.

De GTK frontend werkt wel normaal.

Updated by Alguno over 3 years ago

Dat probleempje zou verholpen moeten zijn in http://snapshots.nntpgrab.nl/win64/unstable-trunk/nntpgrab_trunk_snapshot_svn_r1822_setup_x64.exe
Zou je deze eens kunnen proberen?

Updated by Renzzie over 3 years ago

Alguno wrote:

Dat probleempje zou verholpen moeten zijn in http://snapshots.nntpgrab.nl/win64/unstable-trunk/nntpgrab_trunk_snapshot_svn_r1822_setup_x64.exe Zou je deze eens kunnen proberen?

De normale versie doet er nog steeds ~30-40 seconden over
de GTK based versie ~5sec.

Updated by Renzzie about 3 years ago

Alguno wrote:

Heb je nog steeds last van dit probleem met http://snapshots.nntpgrab.nl/win64/unstable-trunk/nntpgrab_trunk_snapshot_svn_r1838_setup_x64.exe ?

Ja. Start nog steeds erg traag op. De GTK versie werkt wel soepel.

Updated by Alguno about 3 years ago

Is dit probleem in de nieuwste beta versie (0.6.92) soms verholpen?
Heb onlangs namelijk nog een wijziging doorgevoerd in Qt welke mogelijk dit issue verhelpt.
Mocht dit niet helpen, dan zou je nog eens kunnen proberen om je firewall software (indien aanwezig)
tijdelijk uit te schakelen. Wellicht dat dat nog helpt.

Updated by Alguno almost 3 years ago

Is dit probleem nog steeds relevant?

Updated by Alguno almost 3 years ago

Kan je aangeven of het probleem ondertussen verholpen is met NNTPGrab 0.7.0?
Mocht je hier geen reactie op geven zal ik de bugreport sluiten

Updated by Renzzie almost 3 years ago

Alguno wrote:

Kan je aangeven of het probleem ondertussen verholpen is met NNTPGrab 0.7.0? Mocht je hier geen reactie op geven zal ik de bugreport sluiten

Heb inmiddels een nieuwe computer. NNTPGrab doet er nu ~10sec om op te starten met 5 items in de queue. Op de oude computer is deze nog steeds traag, hier zo een ~25sec opstart tijd.
Specs nieuwe computer: AMD Phenom II X6 @ 3,2ghz / 8GB

Also available in: Atom PDF